How do I use an existing Android SDK/ANT/NDK?

I already have those frameworks installed, but Fuse forces me to download it to its own folders again?
I tried editing the sdkconfig file with the new paths, but every time I choose the Android target, it rewrites those values...

It's a shame to waste another few gigs on this…


The .sdkconfig is for internal use, and should not be manually edited.

You find the user editable file in C:\Users\[User]\AppData\Local\Fusetools\Fuse\sdkConfig.json, or on Mac ~/.fuse/sdkConfig.json.

I hope I saved you some gigs :slight_smile:

Thanks, but when I build, I still get an error:

Could not find NDK make.exe in C:\ProgramData\Uno\SDKs\AndroidNDK, although I’ve changed ALL paths in the suggested file, and using sdk-downloader.exe I’ve verified all light are lit green…

Did you restart Fuse? I know it is ridcoulous, however we only load the .sdkconfig file at startup of Fuse.

Yes, several times… no luck.

EDIT: I’ve restarted AGAIN, after opening the project, Fuse crashed. Opened again, and this time this error was gone, but I got a new error:

Building SO

make: * no rule to make target libs/arm-eabiv7a/libstlport_static.a needed by libs/

I looked for it in the NDK folder, and found it inside libs/arm64-v8a…

EDIT 2: Updated my NDK version, and it seems ok. Found a new bug though, will open a new post about it (Still couldn’t get a proper APK because of it).

Thank you for your patience, your reports helps us a lot. Good to know that we only support NDK-10d, even though we should support older versions of NDK. I have filed some tickets.

If it helps, the previous version of the NDK I had is 10 (no letters).

What I eventually did (MacOS X) is

  1. Delete the /usr/share/uno/SDKs/AndroidSDK folder (rm -r AndroidSDK)
  2. Create a symbolic link to the existing SDK folder (ln -s /location/android_sdk /usr/share/uno/SDKs/AndroidSDK)
  3. Restart Fuse.