Generating code and dataFontconfig warning


Fuse 1.4.0
MacOS Sierra 10.12.6

When compiling the code of the app, I suddenly get this error message, which is preventing the project to get pass “Loading - Starting project…” in preview mode.

Fuse 1.4.0 (build 14778)
Configuring (1.9 s)
Compiling syntax tree (1.1 s)
Generating code and dataFontconfig warning: no elements found. Check configuration.
Fontconfig warning: adding ~/Library/Caches/com.xamarin.fontconfig
Fontconfig warning: adding fontconfig
(5.8 s)

Build completed in 8.81 seconds
Opening Xcode

An uno clean have not solved this issue yet. Does anyone have suggestions on how to fix this?

Terje Mikalsen

Hi Terje,

the fontconfig warning is just a warning. While extremely annoying, it has nothing to do with your preview (or build) not working.

Does XCode open for you when you’re building the preview? Is the device you’re testing with on the same WiFi as the computer? Do you have the project open in Fuse Studio on the computer? Have you tried running this on another network (there might be blocked ports…)? Have you tried disabling a restrictive local firewall or an antivirus that you might have?

Thank you for the quick reply!

I still am quite new to Fuse, so I feel kind of silly of asking questions like these. I just thought it was a connection in these issues. I will ignore the warning from now on.

However, I did try all of your suggestions to fix the everlasting loading. Nothing did help. Then I tried to run the app locally instead. This is not something I usually do, simply because we are using Azure B2C, making it a hassle to login.

Running it locally finally responded with an error in the log, making it easy to locate the issue. This error did not appear anywhere when compiling for iOS preview. It simply was caused by some some undefined template components.

Once again, thank you for the assistance!

Cheers, don’t hesitate to ask again! Happy Fusing :slight_smile: