Fuse Preview always crashing

Good day\

I have noticed that fuse studio recently crashes every now and then. Any action I try to take from the menu will cause the studio to become unresponsive and then crashes which is kind of annoying.

I uninstalled it and re-installed but that did not resolve the issue and it is still behaving the same way.

Note: I am using the same version in my MacBook Pro and it works fine without any issue.

System Details:

  • Fuse: V1.0.0 (Build 13426)
  • iMac
  • Processor: 3.5 i5
  • RAM: 8G
  • OS: maCOs Sierra

Any suggestion will be highly appreciated

i have the same issue and i am on mac book pro , even right click and try to select from submenu it will end with crashe .

System Details:

-Fuse: V1.0.0 (Build 13426)
-MacBook pro
-RAM: 16G
-OS: maCOs Sierra

Thanks for reporting! We’ll investigate this shortly and get back to you.

any update ?

i am missing time of Pro version trial , as i am not able to do any thing .

please help here .

Hey GMB,

it looks like the root cause was found for this very recently, and a fix was introduced. You can expect for this to be solved in a near future release. No ETA at this point, but you’ll get notified when it’s available.

thank you for your response ,

will fuse team be kind to extend my trail after this issue get addressed ? as i reallt would like to go for the pro version .


Yes GMB, your trial will of course be extended. Thank you for reporting issues and bearing with us until they are fixed.

Thanks @UIdis, I am glad to know that a solution for this issue is on the way!

Hi, an early release of Fuse 1.0.1 is now available at https://www.fusetools.com/downloads/channel/qa. Can you please try this one, and see if it fixes your issues?

Hi ,

I do confirm that the is issue is still not resolved .

I am happy to send any more information you may request


GMB can you please describe exactly in which scenarios Fuse crashes for you now?

Hi Anders,

Unfortunately, the issue is still there even after installing the pre-release version. The tool becomes unresponsive for example and then crashes:

  • When I try to select an option from the “Project” menu.
  • When right clicking on the current scene and hitting the “Back” button to go to the previous scene.

These are just few examples of many. It happens with other menus as well. I am not really sure why this is happening even though I am using the same version on my MackBook Pro without any issue


Same problem with MacBook Pro, whenever I try to use any item in the menu, the menu expand fine, but once I hover over any item in the menu, Fuse becomes unresponsive, hangs and then crashes.

Currently, I’m doing everything without using the menus (external editor and property panels only). If there is any logs I can send to help you find out the bug, please tell me which.

Fuse is great tool, this problem will be overcome, keep up the good work, I actually just signed up today to the Pro plan.

Ali and coderavine - could you two please post all details about the systems that you have Fuse crashing on? OS version, model numbers, CPU/GPU details, anything… maybe some custom software installed?

That could help us understand where this one is coming from.

Hi UIdis,

Please see below my system specs:

  • OS macOS Sierra Version 10.12.5
  • iMac (Retina 5K, 27-inch, Late 2014)
  • Processor 3.5 GHz Intel Core i5
  • Memory 8 GB 1600 MHz DDR3
  • Graphics AMD Radeon R9 M290X 2048 MB
  • Storage 1T SSD

Please let me know if any additional information would be of a great help to troubleshoot the issue. I don’t have specific custom software installed



My system is:

  • MacBook Pro (Retina, 13-inch, Late 2013)
  • macOS Sierra 10.12.5
  • 2.8 GHz Intel Core i7
  • 8 GB 1600 MHz DDR3
  • Intel Iris 1536 MB
  • Fuse 1.0

I killed all Fuse processes in Activity Monitor, lunched Console, and run Fuse again, these log entries caught my eye:

UNIX error exception: 17
0xee93810 - PerformanceMonitor::measureCPUUsageInActivityState: Process is using 110.2% CPU in state: VisibleNonActive
0xee93810 - PerformanceMonitor::measurePostBackgroundingMemoryUsage: Process was using 124022784 bytes of memory after becoming non visible.

It’s not only Fuse that hangs when I use the menu, but even if I choose Quit from Fuse Tray it also hangs.

If you would like I can send you the all the log entires, but then I have to send it by email.

I also tried v1.01 and same problem remains. in Activity Monitor Fuse spike to 100% CPU and then crash, only when I hover over any menu item.

Not sure but i found this in my system logs

Jun 19 03:44:24 MacBook-Pro-3 Fuse Tray[15524]: objc[15524]: Class VCWeakObjectHolder is implemented in both /System/Library/PrivateFrameworks/AVConference.framework/Frameworks/ViceroyTrace.framework/Versions/A/ViceroyTrace (0xa6662090) and /System/Library/PrivateFrameworks/AVConference.framework/Versions/A/AVConference (0xa6678ea4). One of the two will be used. Which one is undefined.

And i had the same as Ali , 100% CPU usage before it crash .

My system is: - MacBook Pro (Retina, 15-inch, Late 2016) - macOS Sierra 10.12.5 - 2.8 GHz Intel Core i7 - 16 GB - Fuse 1.0.1

Thanks for reporting back! We’ll investigate this shortly. Unfortunately, the only workaround in the mean time is to not use the menus, but instead do things manually.

For instance, opening the project in editors and terminals can be done in those programs. Selection and Compact view can be toggled from the main UI. Preview can be started from a terminal by doing fuse preview -t<ios|android>. We realise that this is cumbersome, and hope to have a fix out soon! Sorry for the inconvenience in the mean time.

Thank you Anders ,

i have a childish idea however ,

@Ali and @coderavine ,

Do you have arabic keyboard enabled in the system ? i am just thinking about common things between our systems that may be the source of the issue .