Fuse Debugging no longer waits

Since upgrading to Fuse Tools version 1.0.0 (build 13426) and running on OSX version (10.12.4), I am no longer able to debug fuse apps using Visual Studio Code (1.12.2).

Prior to upgrading Fuse, on version 0.37.x, whenever I executed the following CLI statement,

fuse preview . -DDEBUG_V8

I’d get this response that informed me to attach my debugger and get breakpoints to fire for debugging.

DEBUG_V8: Waiting for a debugger agent to connect on port 5858...

Now when I execute the same statment for debugging, I get a different response (below) and unable to attach my debugger to the Fuse app,

[@~/safezone/projects/mobile/fuse/samples/instafit] $fuse preview . -DDEBUG_V8
Fuse 1.0.0 (build 13426)
(0.7 s)
Compiling syntax tree
(2.4 s)
Generating code and data
(3.0 s)
Build completed in 6.11 seconds

How do I get the Fuse app to halt installation so that I can “press play” to attach the VS Code debugger breakpoints?

Hi calvin,

this is a known issue that is being worked on. For details see this thread.

Hi Uldis. Thanks for the quick update, and sorry about the overhead with the duplicate report. I tried searching on the community forum for ‘debug’ and ‘-DDEBUG_V8’ and got this summarized grouping of hits.
All Forum (802) Docs (79) Blog (1) Examples (1)
I was screening for a hit with ‘Bug’ but didn’t see any. I also tried the Slack channel but didn’t see any evidence of the bug that was reported and being worked on. For my own knowledge for next time, is there a different way to have located the bug report that you linked me to?

That, calvin, is another known issue :slight_smile:

There’s very little you could have done to look up that thread, since the search could/should work better. There’s a ticket on that too and I’m sure we’re looking at improvements on this in not-so-distant future.

The Fuse 1.0.1 pre-release, available at https://www.fusetools.com/downloads/channel/qa, now allows you to pass defines to the preview command again, so it should now work to start Fuse with fuse preview . -DDEBUG_V8.

Thanks for your report!

I’ve just downloaded the latest version and thrilled to confirm that I’m now able to attach my debugger using: $fuse preview . -DDEBUG_V8. Thank you for the fix and update.