FATAL ERROR: This version of Xamarin.Mac requires Mono, but found Mono

Hello! I installed Fuse SDK globally by running “sudo npm install -g fuse-sdk”.

I made a simple test project and it build fine on Android, but running “sudo uno build ios” to build iOS it says “FATAL ERROR: This version of Xamarin.Mac requires Mono, but found Mono”.

Running “mono --version” in the terminal says “Mono JIT compiler version (2020-02/6051b710727 Tue Jun 14 15:01:21 EDT 2022)”.

I uninstalled Mono and tried to build iOS again, but it gives me the same error message. Seems that the build script is not locating Mono or using an older version of it from somewhere…?

I’m using macOS Ventura 13.2.1.

I reinstalled Fuse SDK and got a bit further. Now the error is:

warning: Building targets in manual order is deprecated - check “Parallelize build for command-line builds” in the project editor, or set DISABLE_MANUAL_TARGET_ORDER_BUILD_WARNING in any of the targets in the current build to suppress this warning

/Users/mattitihverainen/Fuse/test/build/ios/debug/test.xcodeproj: warning: The iOS deployment target ‘IPHONEOS_DEPLOYMENT_TARGET’ is set to 9.0, but the range of supported deployment target versions is 11.0 to 16.1.99. (in target ‘test’ from project ‘test’)

/Users/mattitihverainen/Fuse/test/build/ios/debug/test.xcodeproj: error: Signing for “test” requires a development team. Select a development team in the Signing & Capabilities editor. (in target ‘test’ from project ‘test’)

warning: Run script build phase ‘Run Script’ will be run during every build because it does not specify any outputs. To address this warning, either add output dependencies to the script phase, or configure it to run in every build by unchecking “Based on dependency analysis” in the script phase. (in target ‘test’ from project ‘test’)


I opened the generated Xcode project and after fixing the folder permissions the project build and simulator run fine so everything should be ok so far.