FATAL ERROR: Build failed for Android

Experiencing an Android buil issue on a Mac, Fuse and Fuse Local preview and iOS preview run fine.

when running fuse build --target=Android -v, the following messages are thrown in shell:

[mergemanifest] Found modified input file
[mergemanifest] Merging AndroidManifest files into one.
[mergemanifest] Manifest merger disabled. Using project manifest only.
     [echo] Handling aidl files...
     [aidl] No AIDL files to compile.
     [echo] ----------
     [echo] Handling RenderScript files...
     [echo] ----------
     [echo] Handling Resources...
     [aapt] Found new input file
     [aapt] Generating resource IDs...
     [aapt] /build/Android/Debug/{removed-app-name}/app/src/main/bin/AndroidManifest.xml:59: error: Error: No resource found that matches the given name (at 'value' with value '@integer/google_play_services_version').

/Library/Application Support/Fusetools/Fuse/Android/AndroidSDK/tools/ant/build.xml:653: The following error occurred while executing this line:
/Library/Application Support/Fusetools/Fuse/Android/AndroidSDK/tools/ant/build.xml:698: null returned: 1

Total time: 2 seconds
(unknown): E0200: Android build failed -- rerun with '-v' for more information
(3,482.33 ms)

Build completed in 59.88 seconds.
    0 Warning(s)
    1 Error(s)

Error Summary

(unknown): E0200: Android build failed -- rerun with '-v' for more information
FATAL ERROR: Build failed.
fuse: Errors were encountered while building the project

Tried reinstalling Google Play Services and Android Support Library, did not help. Tried running fuse build --clean and then building, did not help.

Got to a successful build when removed the following from .unoproj file:

  "Android": {
    "Geo": {
      "ApiKey": "{removed-my-apikey}"

Having said that, I’d still need the Android section there as I intend to use a MapView and other platform-specific things.

Any suggestions for further debug actions?


We have no idea how to attack this by just looking at these logs. Can you please send us a complete test case?

Problem solved by including "Fuse.Maps" in .unoproj file under "Packages".

Edit: So, basically, two things:

  1. Do not put Android/Geo section in your .unoproj without including Fuse.Maps in Packages.
  2. Fuse should probably react with a hint to include Fuse.Maps, not with a Fatal build error.