Fail to connect to proxy

On OS X, telnet separates the IP and the port with a space, not a colon, so you have to do telnet 12124 rather than telnet

You are right that a telnet server usually runs on port 23, but in this case we are just using the telnet client to connect to the Fuse process which listens on port 12124 when a preview instance is running.

Again, is local preview working?

Yes, local preview works fine for me.

Thanks for highlighting my error with the use of telnet. Now when I run telnet calvin@~/Documents/Safezone/Projects/fuse/examples/hikr$ telnet 12124 as you’ve outlined, I get this output:

telnet: connect to address Connection refused
telnet: Unable to connect to remote host

Can you please make sure that local preview is running, and then run the telnet command again, both to your public and your loopback ip?

telnet 12124 and telnet 12124 (It’s important that local preview is running while you do this)

Another thing that could shed some light on this: After you run fuse preview -tios and the project opens in XCode, can you please try starting it in the iOS simulator instead of on your actual device?

With local preview running, I get the following output from my terminal.

calvin@~/Documents/Safezone/Projects$ telnet 12124
Connected to
Escape character is '^]'.
calvin@~/Documents/Safezone/Projects$ telnet 12124
Connected to localhost.
Escape character is '^]'.

I get the same error trying to preview on my iPhone7 regardless if I start it from XCode (upgraded to 8.1 to support iOS 10.1 on iPhone) or by tapping the app on the phone itself.

Thanks! Can you please try running preview in the iOS simulator inside Xcode instead of on your actual device?

If you’re unfamiliar with the iOS simulator in Xcode, you can read more about it here

Hi Anders, I am able to successfully build and run the app through the XCode simulator. This worked for the iPhone5 and iPhone7 Plus targets.

Ok, then it seems like Fuse is working just fine, and that you phone is just unable to connect to your computer. Are you 100% sure they are connected to the same wifi? Are you running any sort of firewall on your computer?

I have not installed any Firewall products on my laptop. And yes, I’ve just re-verified that both my iphone and laptop are connected to a wifi network named “ibiza 5GHz.”

Will you help me understand how running the XCode Simulator alone confirms Fuse is working correctly? I’ve perused the iOS project files and did find a whole lot of Fuse source files and was suprised to the find the Javascript files – essentially in their same format rather than all C++/Objective-C transformed files. There’s some wondeful machinery and magic behind Fuse that I would very much like to understand.

The fact that the iOS simulator app works, means that it is able to connect to Fuse. Also, the fact that you’re able to connect with telnet 12124 means that Fuse is able to bind and listen on that port on your public IP.

I’m running out of ideas now, but the last thing you could try is to find an iOS network debugging app and see if you are able to telnet to 12124 from your iPhone.

As for the inner workings of Fuse, I’m not sure we have an article explaining all of it, but basically UX compiles to Uno, and further to C++ and OpenGL for optimal performance. JavaScript runs on a separate thread, and is not used to control the UI, ensuring that everything that touches the UI is heavily optimised. Unlike UX, JavaScript is not compiled until it reaches the JavaScript engine’s JIT.

Edit: The first paragraphs here also explain a bit how Fuse works.

Thanks for that summary. I’ll look into an iOS network debugging app and will possibly reinstall my OSX and/or buy a new machine that I can dedicate for Fuse Development if needed. I will update the post once I have new insight.

This sounds like a software issue, so hopefully the app will reveal the issue, or a re-install will help. I don’t think the hardware could cause an issue like this. Good luck with debugging!