Default Fusetools icon on iOS


i need information, what must i do, when i want to change the default fusetools icon with my custom icon on iOS platform ?
Now i use these parameters for icons with my custom icon in my project file:

 "Icons": {
            "iPhone_40_2x": "assets/icons/iOS/Icon_40@2x.png",
            "iPhone_40_3x": "assets/icons/iOS/Icon_40@3x.png",
            "iPhone_60_2x": "assets/icons/iOS/Icon_60@2x.png",
            "iPhone_60_3x": "assets/icons/iOS/Icon_60@3x.png",

But that don’t help me replace this default icon.
This is screenshot from my iTunes Connect account of my uploaded application.

You can see, that App Icon is my custom icon in General App Information section but in section Included Assets is it still default Fuse icon.

Hi Donald,

for a quick reference, this is something that I personally have used before in my projects with great success:

    "Icons": {
      "iPhone_29_2x": "Icon-App-29x29@2x.png",
      "iPhone_29_3x": "Icon-App-29x29@3x.png",
      "iPhone_40_2x": "Icon-App-40x40@2x.png",
      "iPhone_40_3x": "Icon-App-40x40@3x.png",
      "iPhone_60_2x": "Icon-App-60x60@2x.png",
      "iPhone_60_3x": "Icon-App-60x60@3x.png",
      "iPad_29_1x": "Icon-App-29x29@1x.png",
      "iPad_29_2x": "Icon-App-29x29@2x.png",
      "iPad_40_1x": "Icon-App-40x40@1x.png",
      "iPad_40_2x": "Icon-App-40x40@2x.png",
      "iPad_76_1x": "Icon-App-76x76@1x.png",
      "iPad_76_2x": "Icon-App-76x76@2x.png"

It is important to note that your custom icons only get used when you make a release build of the app, not a debug/preview one. To make a release build, you need to run a command similar to this one:

uno build --target=iOS --configuration=Release -d

Aside from that, you can check what the icons look like in XCode before exporting the build to iTunes connect.

Thank you for your information, but it has not helped me.
The solution of this issue is only edit icons of application directly in XCode. Fuse project file does not provide these icons correctly. It’s missing option for iPhone Notification iOS 7 - 10 with resoltion 20pt (2x and 3x).

20? I’ve never seen that size anywhere, but it might just be me.

Have you tried adding corresponding strings to .unoproj? Something like this:


No i don’t tried it. It were not in documentation of Fuse :slight_smile:

So it worked?

Now yes