Crash on Android 7

Hey there, uh sorry for the trouble, but i have an issue that i dont know how to fix.
you see, im making an simple app who gets feed by an homemade API, and so far so good. (putting aside my terrible practices at code),

the issue is when i try to pass the app to a friend with android 7 (samsung s8) the app crash on start. i tried on few emulators of android 7 and the same issue . could you help me please? by the way sorry for the terrible english.

Hi Alberto,

you will need to show some more details, otherwise it’s impossible to help. You say the app crashes on start - so what does the app do on start? Does it request some permissions, or…?

Also, have you tried running a local build of the app with fuse build -tandroid -r -vv? That should give you a run-time log in the console, so you could see some more details on why the crash is happening.

First of all , thanks for your response.

about the local build, i will try to get a device with android 7 to play with. (my friend lives kinda far away)

about the start:

1.- the app ask for permission to use the GPS.

2.- the app ask the API for some data.

3.- the app shows the data.

4.- waits for user input.

maybe the unoproj could help?

  "Packages": [
  "Includes": [
   "Android": {
	   "Geo": {
	        "ApiKey": "******************"

The .unoproj does not suggest anything in particular, no. Except that RootNamespace should be a reversed fully qualified domain, according to the specs.

You will need to find when the app crashes. It could be related to the permission request, so a log from the crash is essential.

Hi, looks like the problem was found, (at least one of them).
The console log says provider doesn't exist:gps and when i kill the following line: location.getLocation(3000) all work like should be.

so… i will need catch that, but a simple try catch does not work, neither the promise catch… so any idea what should i do?

Could you please create a complete, minimal reproduction that triggers the crash? We would also need details on the affected devices: brand, model, particular version, OS etc. (“Samsung S8” is not enough to go with).