Can´t preview in Android

hi, I was searching for a solution to this (first of all I´m new to Fuse and to app developement as well :slight_smile: ). I installed Fuse, Android SDK (and reinstalled it) and checked via console that all the sofware needed was there.

I can preview LOCAL but cannot preview in Android (working in a Windows 10 machine).

This is the Build Result I get:


Configuring (3.061,89 ms)

Parsing source code (2.643,80 ms)

Compiling syntax tree (11.524,32 ms)

Generating code and data (21.905,57 ms)

Building native target 1/2: 2/2: FuseApptest_01-debug.apk (16.588,95 ms)

Build completed in 55,74 seconds. 0 Warning(s) 0 Error(s) C:\Users\Fernando\Desktop\APPS\FUSE_APPS\\Simulator\Android\run.bat

Build complete.

Trying to uninstall existing version of APK

“C:\Program” no se reconoce como un comando interno o externo, programa o archivo por lotes ejecutable.

(exit code: 1)


I have tried editing run.bat (as have read another post in this forum to do so) but after I set the app to preview, the run.bat returns to its original state, and I keep getting the same errors.

What can I try to finally get my Android preview? Thanks in advance! (btw: Fuse looks very good so far, I know all of this are setup glitches, hope to have them solved soon, again thanks a lot.)


Thanks for reporting this. I’ve filed an internal ticket and someone will look into this shortly.

Thanks Anders, I´m anxious to know if there´s any workaround to the problem, whether it is a common issue or something in my setup. Do you need any more information to look into it? Again thanks.

The fix is coming soon, but in the meantime you can implement it yourself. :slight_smile:

If you apply the changes (e.g. use “%ADB%” instead of %ADB%) in %programdata%\uno\Packages\UnoCore\0.19.6\Targets\CPlusPlus\Android\run.bat it should be all ok. (This is the source from which all the other run.bat files are copied. )

Thanks Remi, will try it asap. I edited several times the file run.bat, but the one in the same app directory, and every time I run the preview it would go back to its original state, deleting my changes. I´ll let you know, again thanks a lot for the answer.

IT WORKS!!! This is the report after the BUILD COMPLETE, in case it is useful for debugging (BTW the device is a Samsung Tablet, SM T700):


Build complete.

Trying to uninstall existing version of APK

  • daemon not running. starting it now on port 5037
  • daemon started successfully Failure [DELETE_FAILED_INTERNAL_ERROR]

Installing new version of APK pkg: /data/local/tmp/FuseApptest_01-debug.apk


3626 KB/s (24459609 bytes in 6.587s)

Starting APK on device Starting: Intent { act=android.intent.action.MAIN cat=[d] flg=0x10200000 cmp=com.FuseApptest_01/.FuseApptest_01 }


Once again thanks to Remi and Anders, now I can go on with the R+D!

Nice to see you got it working! :slight_smile: We’ve made a proper fix to this internally, which will roll out soon.

The newly released 0.9.6 includes a proper fix to this problem.