Android\sdk\platform-tools\adb.exe Not Found

In the fuse log file I get…

2022-06-29 04:03:28,040 [12928:21] ERROR fuse X - Failed to reverse port
Fuse.Preview.AndroidReversePortFailed: Tried to reverse adb port ‘tcp:51976’ ‘tcp:51976’. However failed with: Android ‘adb’ was not found at C:\Users\Steve\AppData\Local\Android\sdk\platform-tools\adb.exe
at Fuse.Preview.AndroidPortReverser.ReversePort(Int32 remotePort, Int32 localPort)
at Fuse.Preview.AndroidPortReverserExtensions.ReversePortOrLogErrors(AndroidPortReverser portReverser, IReport log, Int32 remotePort, Int32 localPort)

I can see that platform-tools\ does not exist. I tried reinstalling Fuse X and using Tools > Install Android SDK with no luck.

How can I get this installed?

Cheers!!

Part 1: Resolved

I found the exe at SDK Platform Tools release notes  |  Android Developers and copied to the sdk directory.

Now I only have

Fuse.Preview.AndroidReversePortFailed: Tried to reverse adb port ‘tcp:50956’ ‘tcp:50956’. However failed with:
at Fuse.Preview.AndroidPortReverser.ReversePort(Int32 remotePort, Int32 localPort)
at Fuse.Preview.AndroidPortReverserExtensions.ReversePortOrLogErrors(AndroidPortReverser portReverser, IReport log, Int32 remotePort, Int32 localPort)

to resolve.

Any ideas??

Ok. I got past the reverse port problem by using .\adb.exe kill-server and then .\adb.exe start-server.

I still cannot see the preview which is where I started. I checked my openGL version prior and I have 4.6. I do not have the intel devices listed on other pages.

I see Zero4 → C:\Users\Steve\Documents\fuse X\Zero4\build\dotnet\preview\Zero4.dll

in the log window. Is it possible this is where my problem lies?

Or do you have ideas that I can pursue??

Cheers!!

try to reinstall the VCRedist 2010 and VCRedist 2013