Android Builds can't be installed

Fuse version 0.36.0 (build 11838)
Copyright © 2017 Fusetools

OS: Windows10 Home (Version 1607)

Followed tutorial to learn how to make apps with fuse (hikr), preview is working perfectly, then i wanted to build it for my mobile (Honor8, EMUI5.1) and even if the build was successful, the APK won’t install

To build the APK I typed:
fuse build --target=Android --configuration=Release
The build is successful, always, no errors, no warning, then moved the APK to my mobile and it just can’t be installed, i dunno if i’m doing something wrong or it’s not working…

What do you mean can’t be installed. What does it say? Do you get any error message?

Also, if you add -r to the build command then the app will be automatically deployed to your USB-connected device.

It sais (on the mobile phone)

App not installed,
The package might be damaged

Also, i tried to use -r or even -f to force a new build, but no good result

Should i try to reinstall something?

Can you try on a different android device? If it still doesn’t work, can you share the built .apk ?

I’ll try find some other android device with a different OS, i’m sharing the APK anyway:


I also tried to download the code directly from your github (chapter4) and build it:

$ fuse build -t=Android -c=Release
Uno 0.47.12 (build 5229) Windows 10 x64 55058c5

Configuring (3.0 s)
Compiling syntax tree (1.8 s)
Generating code and data (13.5 s)
Building Android app
2/2: hikr.apk
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

Build completed in 88.02 seconds

But in the end, when i put it on my phone, it still doesn’t work

-found another mobile device: Samsung S3, Android 4.4.2;
Still doesn’t install, but it gives no error message (guess it’s a system issue)

As i’ll be in the office i’ll try with a Samsung S7 updated to the last android version

Thanks ZioCain, this is all very useful. I’ve been able to replicate the bug here and will starting looking for a fix now.

Hi again ZioCain,

We found a regression in how we handled signing of apps. When you build for release Fuse looks for signing info in the unoproj and if it doesn’t fine it then it is meant to fall back to using the debug-keystore. However since we moved to gradle this was no longer handled by the build system so we now make sure that Fuse handles it for you.

We now have a fix internally and we are planning to make a patch release containing this fix.

Thanks again for reporting this and all the details.

Glad i’ve helped!!!

Looking forward for the patch! Fuse really helps out in the making of an App!

Thank you!

Hi there!
This should now be fixed in the 0.36.1 patch release