Android build fails - make.exe not found


preview works perfect, building for Android fails:

ERROR: make.exe was not not found in ‘\prebuilt\windows**’

(yes, there is 2x ‘not’)

Windows 7 Fuse 0.9.8 5700

Hi, by any chance, do you know which version of NDK you have?

Forgot to say, that the version may be found inside RELEASE.txt (at least in NDK10d). RELEASE.txt should be located in the root of your NDK installation.

Solved it. The NDK was somehow corrupted. I re-installed everything and not build is working.

Good to hear it’s working now!

Hey I am pointing to the right path in my D drive custom location for NDK,it is telling me ndk-build not found

Hi, which NDK version do you have?

Im getting this same error. Is there a documented solution? I also cant seem to find the folder with the release.txt requested in this thread. Totally first android experience ever. Thank you.

Im on Window 10. This is the command and output.

C:\Users\aarmand\projects\list-ui>fuse build --target=Android --run
Uno 0.35.9 (build 3785) Windows 10 x64 ba430e2

Configuring (3.66s)
Installing dependencies
stuff: GET
stuff: GET

Compiling syntax tree (2.71s)
Generating code and data (21.55s)
Building Android app
ERROR: make.exe was not found in ""\prebuilt\windows**"
(unknown): E0200: Android build failed

Build completed in 52.02 seconds
    1 error
fuse: Errors were encountered while building the project```

Hi, have you ran fuse install android?

I sure didnt at that point. It not very clearly stated that its necessary either. Might be important to highlight that in the install docs. Thank you for the reply.

Hi Alain, sorry you missed that part. It is however listed in both the OS X and Windows installation guides:

In order to do Android exports and on-device preview you will also need to install the required third party SDKs. See the Preview and export section.

as well as the first point under the docs on Preview and Export (see

I love Fuse. You guys are visionaries. So check this out. This the experience discovering Fuse as I experienced it.

  1. Landing Page., then click “Lets Do This” button.
  2. Download Page, then click Mac or Windows Download.
  3. Program Downloads and installs.
  4. Program opens. You are invited to try examples.
  5. You download an example and run local preview.
  6. Build Fails.
  7. Go to docs, read(see
  8. Run ‘fuse install android’
  9. Build succeeds.

I would recommend that the ‘downloads’ link sends the potential user to an installation guide which has the steps that need to be taken if only to remove this initial frustration doubt felt on the first experience. 1. Download. 2. Run ‘fuse install android’ 3. Choose example. 4. Run example.

I hope this feedback is useful from an user onboarding perspective. Looking forward to great things from Fuse. Hell, If you have use for a remote internship of some kind. Please dont hesitate to reach out. I’m in Paris so timezone not an issue.


I totally agree that we need to do a better job on the onboarding here, especially with the error message you got (which there is a reason for being slightly convoluted, though it shouldn’t reach the user like that).

Just to clarify though, in your post you say you try local preview and the build fails, but in your post earlier in the thread the build command listed is fuse build --target=Android --run which is not local preview. So in that case, you do need to run fuse install android first. It should however not be necessary when running local preview on your computer.

What happened specifically when you selected local preview as your target?

So local failed. Then i tried building android. That failed. I guess i only posted the second try.