WhileHoovering & WhilePressed not correct working on Version

The event handlers WhileHoovering and WhilePressed are not working as expected on version On the version before they worked perfekt.

Now there is a flickering when chaning the background color on hovering. After pressed backcolors of uninvolved panels are changed.


Thanks for reporting this, we will investigate. Our release testing did not pick up any regressions. Can you please provide a test case that illustrates this problem? Thanks.

I’m unable to reproduce the problem with the sample project using the newest in-house build.

Note that the WhileHovering remains active even when WhilePressed is active. You’ll end up getting a ombination of the two colors. Perhaps this is part of the unexpected color you’re seeing.

Duration="0.0" is implicit, you don’t need to specify this on an animator.

Hi Anders,

I sent you a mail yesterday. I’ve you didn’t got it, please inform me.

Sven: We got it, and edA-qa has been looking at it, without being able to reproduce the problem you describe:/

Ok, here (http://1drv.ms/21fyKwX) is a video of the problem… The flickering is not visible because of the qualitiy of the video…

Hi Sven, just a tip: you can use Quicktime to perform 60 FPS screen recordings on OS X. That should help us get a better look at the issue:


(after you click that you can choose to select an area of the screen to record - use that to just record the preview window)

For me it looks as if the hover state is not cleared… This would explain the flickering: on a second hover the color is change immediately and then the default hover animation is changing the color once again…

@Bent: thx


Have you tried your code in the latest version of Fuse (0.24)? It has some bugfixes that might be related to this.