Video not playing, only sound available in the background

I would like to report Video playback problems on Android preview. I am trying to put Video (mp4) as a background of one main Page.
I can put static image and it works. When I place the video in, I can hear the music from that video, but not visual part.
I can send you a Log file to dropbox. Just provide me a link.
New app recreated and same code used and still does not work. Minimal code>

<Page Name="login">
		<Video Layer="Background" File="friends.mp4" IsLooping="true" AutoPlay="true" StretchMode="UniformToFill" Opacity="0.5">
		<Blur Radius="4.75" />
	       <Grid Rows="1*,1*">
			<StackPanel Alignment="Center">					 
				<WhiteText FontSize="45" Alignment="HorizontalCenter">my app name</WhiteText>				 
Fuse version 1.2.1 (build 13974)

OS: Win 10 x64 Pro.

That video of yours probably uses a codec that the device you’re testing on can’t play. Examine the file and convert it to a more widely used codec.

Since you may ask, mp4 is not a codec, but just a container format. It’s what is inside what matters.

Hi Uldis,

More interesting thing is that I did try it with other files too. Also with one of the Fuse examples (video only). There must be something else what makes a conflict. I left code as minimal as possible, removing everything else.
I will try on different device.
PS: I have noticed that blur does work only on pc preview, but not on Android. Also the buttons (elements) drop shadow. There is no effects available on Android preview.

What android device does this happen on? Can you try building hikr and see if the video shows there?

I have sorted that out. I have recreated new project, copy code to new project and made some modifications (split views to separate UX files). It works now. No clue why and how. Hikr project worked fine.
I am now facing other problem but I’ll post other topic. Input fields are not showing up on first app load. I have to turn the phone to landscape and fields shows up. Also works if I just lock and unlock the phone. PC preview works fine.
Bu I DO LIKE FUSE A LOT! :slight_smile:

If a clean project works, i’m assuming uno clean might solve the issue, might be the bundler having a hickup due to something. Try it if you ever have the same issue again, might work.

I did try uno clean. I am also facing other strange problems. Fuse freezing for example, printing out errors (variable and function names not found in context) in Log console. When I rebuild errors disappears, after few refreshes they show up again.

If you can create seperate threads and reproductions for these errors, i can have tickets made so they can be investigated

Yep I will when I get back home. I’ll paste url here.

Here is first problem with AddingAnimation to StackPanel where is Grid main content.