Very strange javascript bug

fuse version: v0.24.0 (build 7243)
os: windows 10 home ver: 1607, build number:14393.51 (anniversary update)

I wanted to make a page navigation system using javascript.
Multiple ux files (landing.ux, main.ux, hlp.ux etc).
And a javascript to navigate between them.
Then it showed me an error.
Deleted the script, tried to create a new to see it is me who did it wrong or not.
Since then it give an error to anything that javascript regardless the syntax, the monitor says there is no error.
Even an empty javascript tag.
Attached screenshots.

if the screenshots not visible:
update: deleting the other ux files did not solved the problem

Hello, and thanks for your report!

I suspect the problem is that ux:Names are not allowed to be just numbers, but have to be valid identifiers (i.e. start with an alphanumeric and continue with either numbers or alphanumerics). Does it work if you change all the ux:Names e.g. from 1 to x1? I’m going to create an internal issue about improving that error message.

If that does not solve the problem, can you post your code?


Yes it solved the problem.

Thank you :smiley: