Update about local view issue on Windows 10

Hi Fuse team,

Thanks for developing Fusetools. For local preview issue on Windows 10, I want to update some information.

My laptop is running Windows 10 64 bit. I ran “fuse preview” to start local preview and met issue. I checked on Fusetools forum and I knew this problem can also be triggered by driver issues under Windows 10 specific to the Intel HD Graphics 2000 / 3000 / 4000 graphics adapters. I know Fusetools is using to OpenGL 2.1+ to render local preview. Before running local preview, Fusetools will use Windows API to check OpenGL version. It returns 1.1 version. Therefore, we can’t run local preview.

Afterthat, I had used Geeks3D to re-check OpenGL. It returned OpenGL 2.1 and I could run the Geeks3D OpenGL 2.1 demo on my computer. You can check on my picture. Some people reported on internet about Windows API return wrong OpenGL version on Windows 10. I don’t know this is right or wrong. Please re-check and inform for our.

Currently, I must use dual boot Windows 10 and Windows 7 to run Fusetools. Let me know if you have any question.

Thanks, Tan Do.


Thank you for the bug report.

We are querying the version solely for logging purposes. However for some reason the Intel HD GPU (2000, 3000, 4000 series) doesn’t like our bootstrapping approach, and fallbacks to the generic driver for Windows, which causes preview to crash when modern GL methods are used.

We have tried Intel support with no luck, so we have decided to not prioritize the issue. Sorry for the inconvenience, but I will keep you updated if our prioritization changes.