"terminating with uncaught exception of type uThrowable" in version 1.3.0


Our app was correctly working with 1.2.1. But now with 1.3.0, the app crashes after login. This does happen in every environment except desktop preview. I tried to debug in iOS preview and couldn’t find any useful info that explains why it’s happening. Here is the screenshot of the part that I get the exception:

The last valid JS code that is executed before the error is the one that does the routing from LoginPage to the default page of the HomePage.

router.goto('homePage', {}, defaultPageName, {});

Since I don’t know the reason or the code that causes this error I can’t send a sample app. So, is there any other useful piece of information that I can provide to help you figure out the problem?

Thanks in advance,


Hoped that 1.3.1 hotfix release would fix my error since I also get the error after routing with JS. But unfortunately it didn’t: I still get the same error.

@ipek: Do you have a reproduction case that I can try?

Thanks for the reply Erik, but unfortunately I don’t have reproduction case. I don’t understand what the problem is so I can’t make a sample. I can’t debug more than routing from LoginPage to HomePage. That’s why I’m just guessing that this is the problem. But this is such a common case so it would have come up in your test cases. So there must be something different in my app.

If you would like to check out I can upload my app to a private location.

I think I know roughly what the problem is, but I haven’t been able to reproduce it in isolation, so I’m afraid that it’s a bit hard to debug this further.

If you could upload your app here, then I can take a deeper look.

I’ve uploaded the app as infini_error_1.3.1.zip. Forgot to include the necessary steps to login to the zip. So, I’ve also uploaded the readme_infini_error_1.3.1.txt file.

Hope it helps.

Thanks. I’ve tracked this bug down to a quite low-level problem, and we’re working on a fix.

I’m glad it helped!

This should now be fixed in Fuse 1.3.2

Thanks Erik.

Yes, it’s working.