Fuse Community

Taptic Feedback Generator Help

Hey guys! I am currently trying to work with the Taptic feedback generator in iOS. I stumbled upon https://github.com/LuisRodriguezLD/Fuse-TapticFeedback this on the integration site.

First when I tried the example app I got an error due to the fact that
public static extern(!mobile) void Success()
is used two times. To fix it you have to replace the duplicate at the bottom with
public static extern(!mobile) void Warning().

I then switched the Swift Version to 5.0 and tried to compile the app in Xcode. Unfortunately the build fails with six errors which are all of the same nature:

Since I have never touched ObjC, Swift or even UNO I am having a very hard time troubleshooting. I am currently hitting an wall and would be very happy if someone of you could help me out here!

Any help would be highly appreciated!

Support for Taptic Feedback leveraging Taptic Engine is on the way : https://github.com/fuse-open/fuselibs/pull/1338

1 Like

This is awesome! Thank you so much! Hopefully it will be merged soon :slight_smile:

Hey @Ichan_mb! I was currently trying out the new Vibration API.

vibration.vibrate() seems to work but this is due to the older vibration API. Unfortunately neither vibration.vibrate('medium') nor <Vibrate VibrationType="Heavy" /> seems to work.

The Error is:

 Error : 'Vibrate' does not have a property called 'VibrationType'. 

I updated Fuse to the 1.10 RC version and did npm install @fuse-open/fuselibs. Is there anything I am missing?

In order to use this new feature you have to use Uno and Fuselibs from the master branch repo, it is not release yet. You have to clone those libs to your computer, and build the library for your self and then build your app using this local libs

Thank you! I will try it out once I am working on a new project. You seem to be very proficient with uno and obj c. Do you know what the reason might be why this GitHub repo provided above is not working anymore? It is weird because I got it already running half a year ago…

Technically I should be able to just use Apples API via Swift but I can’t find out what the error means.