Some pictures from Camera roll WONT upload


#1

Installed the camera roll package and it’s working beautifully except for one thing. I would say a third of all my pictures in my camera roll simply will not get picked up from the gallery.

I get this in monitor:

LOG: InternalError: ImageSource error: Error while reading JPEG file: Application transferred too few scanlines in Fuse.Resources.FileImageSourceImpl</Users/ryanhashemi/Library/Application Support/Fusetools/Packages/Fuse.Elements/0.43.11/resources/$.uno:608>

Why are some pictures not getting selected? Anything come to mind?


#2

Any idea as to what could be going on here?


#3

Hey Ryan, sorry it`s taken so long to get back to you. Does this happen on both iOS and Android?


#4

Hey Andreas,

We’re only building on iOS for now, so only iOS.


#5

Is it 100% reproducible, so the same images fail every time and the images that work work every time?


#6

Hey Andreas,

It seems like it’s almost 100% reproducible, not really. For instance, there are pictures in my gallery that I have identified that tend to not load… however, this morning I opened the gallery and selected that picture and it loaded. I tried it again later though, and it did not load. Has a 95% failure rate, but will work on occasion.

It seems there are certain pictures that more often that not will not work. It doesn’t seem completely random. With that being said, I’m making sure the pictures are native unfiltered regular pictures (nothing special about them). So, not really sure what’s going on.

Would love some help.

Ryan


#7

Yeah we want to figure this one out too :slight_smile: Naive interpretation is this smells like memory problems.

How big are these pictures? Do you notice it failing more often with larger files than with smaller ones? Have you tried running the picture you got from the CameraRoll through ImageTools.resize to a smaller size and see if that plays nicer? Thanks for your patience with this


#8

Hey Andreas,

Still have this problem. Kind of important as every user will be uploading a profile picture. I tried through ImageTools.resize and still have the same issue. Some images load and some don’t. We’re having the same issues using different pictures on all three of our phones (1/3 - 1/2 of pictures wont load & sometimes the same picture wont load a different time) .


#9

Bumping priority for this one Ryan, sorry about how long this is taking, the team is a little stretched (see our hiring ads).

I’ll push to get this addressed asap, obviously profile pic uploads is a super common scenario.


#10

I think it comes from the same issue, It occurs when I try to resize an image from camera roll.

LOG: InternalError: ImageSource error: 'BundleFileImageSource-failed-conversion': Error while reading JPEG file: Application transferred too few scanlines in Fuse.Resources.FileImageSourceImpl</Users/coskudemirhan/Library/Application Support/Fusetools/Packages/Fuse.Elements/0.47.7/resources/$.uno:616>


#11

Thanks. This is no longer a priority for me - we’ve stopped developing with Fuse and switched to Native.


#12

Yeah, sending an original sized photo from a hi-res camera over the wire doesn’t make sense. For anyone else having a similar issue, Promise.all() and ImageTools.resize() worked for me :slight_smile:,