Sketch file import error

Hello community,

When i try to import a sketch file i get the following error “The application cannot be opened because it has an incorrect executable format” and nothing else in terminal or log file. How can i fix it?

Thank you in advance Dinos L

Hey Dinos,

How are you importing the file? Drag and drop into the Preview window? Command line/terminal?

Is Fuse working as expected apart from this?

I tried both ways but i cannot import it. I get the message i posted when trying to import it with the command fuse import mySketch.sketch using mac terminal

Alright, then it’s most likely a know bug which is actually fixed now, and the fix is included in the next release of Fuse. If you subscribe to updates in this thread I’ll post when the fix is out and you’ll be notified :slight_smile:

I have already subscribed. Thank you for the super fast help ! :slight_smile:

Hey Bent,

I’m coming across this issue too. I’m looking to just import a simple Sketch file to determine how powerful and accurate the feature is. Is there a known workaround or will I have to wait for the fix? If the latter, how long until the fix is issued as an update?

By the way, I am loving Fuse at the moment and am so excited by this closer knit relationship between designers and developers!


Hey Flynn (awesome pirate name btw! :slight_smile:

The release with the fix is actually in QA-testing in our Slack community right now, so it shouldn’t be long.

The Sketch importer is a work-in-progress, and there are parts of it that work great and other parts that work less-great, but as long as you know it and learn its limitations it’s very easy to work around them.

It serves as a proof-of-concept and prototyping tool for how design tool integration will work with Fuse in the future.

I get you Bent, it’s a seriously cool future feature though. I told a designer I know about the idea of it and he thought it was awesome, so excited to see where it can go.

I’ll keep my ears open for the update in the near future so. Thanks for the reply!

So, just to cover what the Sketch importer is right now: it’ll convert your Sketch file to UX markup code, which you can then modularize and reuse around your app. It’ll even create multi-resolution icons and stuff like that. It’ll make images out of anything that needs to be an image, and simple <Panel> pieces for rectangles and such, keeping your color values and things like that.

It’ll also import your fonts and text (if the fonts are not locked off or in an unsupported format. Layout will largely be converted to relative (%) layouts (since you’re supposed to work responsively, not with absolute positioning).

It does a few other things too, but those are for later. :wink:

If you run into issues with it, let us know (and please share the .sketch file with us for debugging) and we’ll take a look!

Excellent. Yes, I’ve been working with a very simple Stech file containing a few shapes and some text. I just wanted to see how it would convert those to UX Markup, but I ran into the same error as Dinos did above.

When I tried:

fuse import mySkectFile.sketch

I got the error:

The application cannot be opened because it has an incorrect executable format. fuse: Import failed: An error occurred

I also tried the drag and drop method on the local preview and got an error also.

The Sketch file I am trying to import is here: Sketch File link - Google Drive

I’m on Fuse 0.11 (build 6183). Thanks!

Yup, that bug is known and fixed. The fix is in the coming 0.12 release that’s currently being tested :slight_smile:

Sweet! :slight_smile:

0.12 is now out, you can get it from

Importing works fine for me!

Thank you guys!! :slight_smile:

Great! :smiley: