Simple WebView not working - does not have a property called Url

hi Guys

I was trying out the Webview Component and it doesn’t seem to work.

Code is: file

I get two errors: ‘WebView’ does not have a property called ‘Url’ and ‘WebView’ must specify required attribute ‘router’

It seems you have multiple things called WebView in your project. Is your file by any chance named WebView.ux? Or do you have a ux:Class="WebView" somewhere?

Hi Anders,

Yes I did have a few things called WebView. I cleared/renamed em and now I’m still getting the same error.

I simplified my test project to get rid of any potential conflicts and this is what i have now:

Main Scene

External Module

yet i still get the same error: file

Looking at the error, it looks like you didn’t change the string inside ux:Class in WebViewPage.ux, but from the screenshot it looks like you did :slight_smile:

Can you try shutting down/restarting Fuse preview and see if that helps? An uno clean might help as well.

Hi Jake

I came back to this project this morning to try your suggestion…but w/o changing anything to the code yet, or doing uno clean, I can see that the error is gone… (Could it be a cache thing?)

Thanks tho

PS I think I’ve gone through all your tutorials on Youtube, from Fuse channel, SDC channel, anywhere I could find it…etc… binged watched the heck out of all of em this past week. top quality stuff!

Glad to see it worked itself out! I’m guessing it was a caching issue, yeah.

And thanks for the kind words! Glad you’ve enjoyed the content. There’s plenty more on the way :slight_smile: