preview local failing on El Capitain, Fuse 0.27.1 (build 7935)

I was cruising along in Getting Started, nicely watching my hot reloads on save. Then the app build failed repeatedly. I restarted fuse and it still failed. I restarted the computer and still failing.
I had just add the code from this section and tried commenting some of it out to see if that caused it. No joy.
https://www.fusetools.com/docs/tutorial/look-and-feel

Here is the console output:

https://gist.github.com/aarmand/56a26952dc7637c4724481a9a37d1684

#UPDATE

I ran another unoproject to test the builder. Cattr ran without any problems. I then did a diff on what I had and what was in the project. When I got to Assets/Background image, i opened the file in sublime text and got a message saying, could not open the image. I then downloaded the image from here https://github.com/fusetools/hikr/blob/chapter-6/Assets/background.jpg into my project. I hit run and it worked. I’m guessing this is not the kind of error behaviour your are looking for so I though i would point it out. Hope it helps.

Hi, I know we have recently been patching a bug related to loading images that are not of the type they claim to be, for instance a jpeg saved as .png.

Could you please try to do file -I <path to the image> in a terminal for any images you’ve used in your app, and see if you see any inconsistencies?

When that is said, the error message from Fuse should of course have been better, this is something we have fixed internally and expect to ship soon.

Uh…when i tried to download the image first time, Mac tried to set extension as webp. I changed to jpg. So that would be consistent with what you said. I fixed it by downloading the image from github and dont have the original anymore. This was the background image from the tutorial.

If you download from Github, the raw resources are hosted as files, so there should be no way for that to magically turn into a WEBP-image.

However: on fusetools.com we use an image optimizing service that serves different types of images depending on which browser you are using, so you’ll always being served the smallest/nicest files. If you try to “Right-click, Save As…” in a modern browser (such as Chrome for example), then getting a .webp-file instead of a .jpg-file is expected behavior, and WEBP files are not supported by Fuse.