Preview fails on

Hi, I oringally installed build 3166 on an OS X 10.10.4 machine. Previews and builds were working correctly. However, after upgrading to build 3278, previews stopped working with the error message shown in the attached screenshot.

I also started with build 3278 on a different 10.10.4 machine and previews are working correctly on that machine.

I have tried the following to resolve the problem without success:

  1. Launching preview from command line
  2. Launching preview from toolbar
  3. Completely removing Fuse and reinstalling 3278 or 3309
  4. Creating a new Fuse application
  5. Rebooting the machine
  6. Running Fuse tools from a different account on the same machine
  7. Removing build 3166 before installing a newer build

I have also tried re-installing build 3166. This does allow previews to work again. However, as soon as I upgrade to a newer version, previews break again.

At this point, I’m out of ideas. Any suggestions on how to solve this issue?

$ fuse preview

Connected to fuse daemon Build started: FullCompile

Building project ‘TestApp’, target ‘DotNetDll’

Build stage changed: Configuring


Uno: 0.5.3309-OSX Project: /Users/gdiveglia/Desktop/TestApp/TestApp.unoproj Packages: UnoCore (0.1.1129), Fuse.Designer (0.1.1173), Uno.Collections (0.1.246), Uno.Geometry (0.1.246), FuseCore (0.1.1173), Experimental.Physics (0.1.1173), Fuse.Animations (0.1.1173), Fuse.Drawing (0.1.1173), Fuse.Drawing.Planar (0.1.1173), Uno.Net.Http (0.1.1129), Experimental.Http (0.1.1173), Fuse.Triggers (0.1.1173), Experimental.TextureLoader (0.1.246), Fuse.Elements (0.1.1173), Fuse.Drawing.Batching (0.1.1173), Fuse.Drawing.Meshes (0.1.1173), Fuse.Drawing.Primitives (0.1.1173), Fuse.Drawing.Polygons (0.1.1173), Fuse.Drawing.Paths (0.1.1173), Fuse.Entities (0.1.1173), Fuse.Gestures (0.1.1173), Fuse.Navigation (0.1.1173), Fuse.Shapes (0.1.1173), Fuse.Controls (0.1.1173), Fuse.Effects (0.1.1173), Fuse.BasicTheme (0.1.1173), Experimental.iOS (0.1.99), Experimental.Threading (0.1.246), ObjC (0.1.99), Fuse.Native.Camera (0.1.1173), Fuse.Scripting (0.1.1173), Uno.Data.Json (0.1.246), Fuse.Scripting.Duktape (0.1.1173), Fuse.Scripting.Jurassic (0.1.1173), Fuse.Reactive (0.1.1173), Uno.Net.Sockets (0.1.246), Outracks.Simulator.Protocol.Uno (0.0.0), Outracks.Simulator.Reflection.Uno (0.0.0), Outracks.Simulator.Client.Uno (0.1.0), TestApp (0.0.0) (3,286.05 ms)

Build stage changed: Parsing source code

Parsing source code

(2,160.58 ms)

Build stage changed: Compiling syntax tree

Compiling syntax tree

(1,136.09 ms)

Build stage changed: Generating code and data

Generating code and data

(1,554.93 ms)

Build completed in 8.14 seconds 0 Warning(s) 0 Error(s) Build ended GL_VERSION: 2.1 ATI-1.32.24 GL_VENDOR: ATI Technologies Inc. GL_RENDERER: AMD Radeon HD - FirePro D300 OpenGL Engine


Could not find a part of the path “/Users/gdiveglia/.local/share/bytecode.bin”. at System.IO.FileStream…ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000] in :0 at System.IO.FileStream…ctor (System.String path, FileMode mode, FileAccess access, FileShare share) [0x00000] in :0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare) at System.IO.File.Open (System.String path, FileMode mode) [0x00000] in :0 at Uno.IO.File.Open (System.String filename, FileMode filemode) [0x00000] in :0 at Outracks.Simulator.BytecodeCache.Save (Outracks.Simulator.Protocol.Reify reify) [0x00000] in :0 at Outracks.Simulator.Reifying.OnEnterState () [0x00000] in :0 at Outracks.Simulator.Application.SetState (Outracks.Simulator.State nextState) [0x00000] in :0 at Outracks.Simulator.Application.OnUpdate () [0x00000] in :0 at Fuse.App.Update () [0x00000] in :0 _wapi_handle_unref_full: Attempting to unref unused handle 0x49d _wapi_handle_unref_full: Attempting to unref unused handle 0x4a0 _wapi_handle_unref_full: Attempting to unref unused handle 0x4a3

Thanks for reporting, we’re looking into it!

I have similar error too. I can only review my project in version v3278 but not in latest version.

However, I tried to use Fuse latest Version v3309 to build in IOS. It can be reviewed in Xcode simulator. That how I am doing debugging now.

Hope the problem can be solved soon.

Ive got the same problem with preview running an empty app: (v 3309 windows 10 pro)


Index was outside the bounds of the array. at Outracks.Simulator.ImmutableList1.Get(Int32 i) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Protocol.Uno\0.1.0\Common\$.uno:line 175 at Outracks.Simulator.Runtime.ScopeClosure.Evaluate(CallSimulatedMethod i) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\Runtime\$.uno:line 185 at Outracks.Simulator.Bytecode.Expression.Match[T](Func</code>2 a1, Func<code>2 a2, Func</code>2 a3, Func<code>2 a4, Func</code>2 a5, Func<code>2 a6, Func</code>2 a7, Func<code>2 a8, Func</code>2 a9, Func<code>2 a10, Func</code>2 a11, Func<code>2 a12, Func</code>2 a13, Func<code>2 a15, Func</code>2 a16) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Protocol.Uno\0.1.0\Bytecode\$.uno:line 105 at Outracks.Simulator.Runtime.ScopeClosure.Evaluate(Expression expression) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\Runtime\$.uno:line 153 at Outracks.Simulator.Runtime.ScopeClosure.Evaluate(Expression e, IScope scope) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\Runtime\$.uno:line 299 at Outracks.Simulator.Runtime.ScopeClosure.Execute(IEnumerable`1 statements) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\Runtime\$.uno:line 139 at Outracks.Simulator.Runtime.ScopeClosure.Execute(Lambda lambda, Object[] arguments) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\Runtime\$.uno:line 120 at Outracks.Simulator.Runtime.VirtualMachine.Execute(Lambda lambda, Object[] arguments) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\Runtime\$.uno:line 97 at Outracks.Simulator.Reifying.OnEnterState() in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\$.uno:line 285 at Outracks.Simulator.Application.SetState(State nextState) in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\$.uno:line 52 at Outracks.Simulator.Application.OnUpdate() in C:\Program Files (x86)\Fuse\Simulator\\Outracks.Simulator.Client.Uno\0.1.0\$.uno:line 43 at Fuse.App.Update() in C:\ProgramData\Uno\Packages\FuseCore\0.1.1173\$.uno:line 194

Hi Håvard,

The issue you’re experiencing seems to be unrelated, but we’re looking into that as well. Thanks for reporting!


A fix will be included in the next release. As a temporary workaround you can try to make the missing directory yourself using mkdir ~/.local/share.

Great, thank you! That solved the issue. I didn’t think it would be as simple as just creating the missing directory. Thanks again!