LocalNotifications payload problem

fusetools: 1.4

os: windows 10.

device: samsung galaxy s6

andoridide: 7.0

and device preview


I want to use LocalNotifications.

I tried to run the source provided in the document ( https://www.fusetools.com/docs/fuse/localnotifications/localnotify ).

The first run was good.

By the way,

This source

LocalNotify.later (4, "Finally!", "4 seconds is a long time", "hmm?", True); 

change like this

LocalNotify.later (4, "Finally!", "8 seconds is a long time", "changed !!", true);

Then run it and touch the [Send notification in 4 seconds] button in the example.

Here a problem arises,

  • “Active status of the app”

If you wait in the active state, it is the value modified by payload

“Finally!”, “8 seconds is a long time”, and “changed !!”

It is normal.

  • ‘App InActive status’

If you run another app or something else

The payload is the value before the modification.

“Finally!”, “4 seconds is a long time”, and “hmm?”

Is this normal?

Is it right to have the same result as # 1?

Did I misuse it? or is there a bud?

If there is a way to fix something, I would appreciate it.

If you’re running a preview version of the app, things like that might happen.

Could you please run a build version and see if the problem persists?

If it does, please post a complete, minimal reproduction that we could copy-paste and run.