Java Version

Hello, i recently updated my java JDK to version Today when i tried to preview my app on my android it gave me an error that i don’t have the required Java JDK installed and when i pressed to install it it downloaded the version.

Fuse Version : 0.25 build 7511
Windows 10 x64

Same thing without changing anything from 0.24.

Fuse 0.25 build 7511 OS X El Capitan 10.11.6

I think that’s a flaw in our system. fuse install android will not try to locate a Java installation if one was found before, but which by now is missing. Although, it should have asked you to provide a path to the java installation, which by default is C:\Program Files\Java\jdk[Version] and in your case C:\Program Files\Java\jdk1.8.0_101.

So could you please try to run fuse install android once more and provide the correct path?

Okay that’s cool but I can’t preview and export to my android phone… it says android build failed and that some android files are missing. Also I tried to open another already installed preview on my device with the same computer but it failed. Everything is the same as with 0.24 build. Is there a way to provide 0.24 build because I really need to test it on android. DEADLINES :smiley:

Can you please provide the full error message you get when you build?

Also, have you tried to clean the project after you upgraded to 0.25? (Open a terminal, navigate into the project folder and then do uno clean)

Yes i always do UNO clean when i upgrade versions!


This is what i get on computer when i try to preview on Android and the second one is what i get on phone when i try to launch the already installed preview of the app

Looks like C\Program Files\Java\jdk1.8.0_73 doesn’t exist. Could you please rerun fuse install android and provide the new path to jdk.

I have already the latest java JDK but the android preview searches for the 0.73 as shown in the error above!

Yeah, that’s wrong, but you are not running fuse install android. The output that you got is just the status of the current Android environment. To actually fix errors that you might have, run fuse install android from CMD.

I tried it but even thought it downloaded JSK 0.73 after that it still said that i don’t have JDK installed and to run fuse install.

You wasn’t able to provide a path to fuse install android when JDK wasn’t found?

it didn’t ask me to provide it with the path.

There is a manually approach too, where you change the JDK.Path part in %localappdata%\Fusetools\Fuse\sdkConfig.json to point to the location of an existing JDK installation.


"Path":"C:\\Program Files\\Java\\[JDKFolder]",

Afterwards, run fuse install android

Okay that did the trick thanks.

Good :slight_smile: