HttpCache and Fullscreen

###App.Window.Fullscreen on Android/iOS It Seems

**this->handle** in app::Uno::Platform::Windowset_Fullscreen

is Null.

Stacktrace from Android:

07-10 13:25:37.429: I/DEBUG(194):                
07-10 13:25:37.429: I/DEBUG(194): Build fingerprint: 'nvidia/wx_na_wf/shieldtablet:5.0.1/LRX22C/29979_515.3274:user/release-keys'
07-10 13:25:37.429: I/DEBUG(194): Revision: '0'
07-10 13:25:37.429: I/DEBUG(194): ABI: 'arm'
07-10 13:25:37.430: I/DEBUG(194): pid: 18911, tid: 18911, name: com.Zpindler  >>> com.Zpindler <<<
07-10 13:25:37.430: I/DEBUG(194): signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x0
07-10 13:25:37.477: I/DEBUG(194):     r0 00000000  r1 00000000  r2 00000001  r3 00000000
07-10 13:25:37.477: I/DEBUG(194):     r4 70423be0  r5 79beb7c0  r6 74216a88  r7 ffffffff
07-10 13:25:37.477: I/DEBUG(194):     r8 fffffffe  r9 41f1d500  sl df34ffb7  fp 00005417
07-10 13:25:37.477: I/DEBUG(194):     ip 422c7f80  sp bea7bc40  lr 702dcb2d  pc 702e7960  cpsr 20070030
07-10 13:25:37.478: I/DEBUG(194): backtrace:
07-10 13:25:37.478: I/DEBUG(194):     #00 pc 004e7960  /data/app/com.Zpindler-1/lib/arm/ (app::Uno::Runtime::Implementation::PlatformWindowImplSetFullscreen(uStatic, Xli::Window, bool)+15)
07-10 13:25:37.478: I/DEBUG(194):     #01 pc 004dcb29  /data/app/com.Zpindler-1/lib/arm/ (app::Uno::Platform::Windowset_Fullscreen(app::Uno::Platform::Window*, bool)+28)
07-10 13:25:37.478: I/DEBUG(194):     #02 pc 0052999d  /data/app/com.Zpindler-1/lib/arm/ (app::Uno::Platform::Window::Fullscreen(bool)+20)

Please post multiple issues in multiple threads, makes it easier to follow up on both! :slight_smile:

Regarding Fullscreen - what are you trying to acheive?

I want to toggle Fullscreen on/off. Meaning to at least getting rid of the Statusbar. Even better, to disable the software buttons on Android. We have our own implementation for Android which is disabling the statusbar, but for iOS it’s a bit tricky:

Objective-C code:

-(void) setFullscreen:(BOOL)enabled {
  // In order to work, "View controller-based status bar appearance"=false must be added to Info.plist
  [[UIApplication sharedApplication] setStatusBarHidden:enabled withAnimation:UIStatusBarAnimationNone];

Btw: I moved the HttpCache bugreport into an other post but I don’t know how to change the title of this one.

On iOS, you can do this:

<iOS.StatusBarConfig IsVisible="false" />