FATAL ERROR: value cannot be null

Fuse version: v0.36.0 build 11838
Mac OS X Sierra 10.12.5 beta (16F43c)
XCode 8.3.1 (8E1000a)

Create a new empty app.
Start the command

fuse preview -tios

output is:
Fuse 0.36.0 (build 11838)
Build started: FullCompile
Configuring (0.8 s)
Compiling syntax tree (2.7 s)
Generating code and data (6.8 s)
FATAL ERROR: Value cannot be null.
Parameter name: source (pass --trace for stack trace)
Build ended
fuse: Failed to compile project

The same error with build, with fuse dashboard and so on. I’ve already tried all the possible way to compile but nothing.
The simple local preview works but the build not.

what can i do?

Hey Aster,

i have the same problem.

See my thread here:


This is a shot in the dark, but does it work if you build with:

uno build iOS --set:Project.iOS.DevelopmentTeam="TESTDEVTEAM"

I think I’ve found and fixed the bug. The fix will be included in a future release.

As a workaround in the meantime you can set the development team manually, as outlined in this article.


Does the latest QA release work for you without using the workaround I posted above?