Error on accessing CameraRoll

In preview on iPhone (6), I get an error when calling cameraRoll.getImage(). I have copied the code from the docs:

var cameraRoll = require("FuseJS/CameraRoll");
  .then(function(image) {
}, function(error) {

Execution halts on openImagePickerWithSourceType in ImagePicker.m on line 22. I get this in XCode

2016-11-28 09:56:55.659430 matodor[5599:1788487] *** Assertion failure in -[UIApplication _cachedSystemAnimationFenceCreatingIfNecessary:], /BuildRoot/Library/Caches/
2016-11-28 09:56:55.663823 matodor[5599:1788487] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'accessing _cachedSystemAnimationFence requires the main thread'
*** First throw call stack:
(0x18dc821c0 0x18c6bc55c 0x18dc82094 0x18e70f79c 0x193d5e450 0x193db5654 0x193b98860 0x193ae3bd4 0x193b52d64 0x193bd8b94 0x193e479c4 0x193e49328 0x193e4be5c 0x193bcfb54 0x100335c34 0x100333d30 0x10125d25c 0x10125d21c 0x10126d0c0 0x10126cbb8 0x18cd162b8 0x18cd15da4)
libc++abi.dylib: terminating with uncaught exception of type NSException

Fuse 0.30 (build 8529)
working on OSX, Sierra 10.12.1

nb. I do have added Fuse.CameraRoll to the .unoproj file.

Also tried to build the app, this gives the same error.

Hey Jeroen

I’m assuming this is iOS 10?

Hi Andreas,

version 10.1.1 to be exact.

Hi Andreas,

on 0.31 this seems to be fixed, although not in the changelog?