Differences between Simulator and iPhone

Hi guys, i’m pretty amazed learning Fuse. I’m running some tests and i noticed some differences between the local simulator and my iphone6.

First is with the Margin property

<Panel Margin="0,5,0,5" Height="100">
    <TitleText Value="{cupos}" Alignment="Right" Margin="0,35,25,0"/>
    <CellSmall Value="{estado}" Alignment="Right" Margin="0,60,25,0"/>

(TitleText and CellSmall are just classes with font, color, and fontsize)


This screenshot is from the simulator, please notice the 0/10 and “Abierto” texts.

And this is from my iphone6, the texts are near the bottom

Second, i’m having trouble clicking some panels that i’m using as TabBar. At the simulator i can click on all of the panel, including the text inside it, and the action is triggered… but in my iphone if i click on the text, nothing happens. I have to click in some area without text to really click the panel and trigger the action.

<Panel ux:Name="tabPending">
    <Rectangle Width="100%" Height="100%">
        <Translation ux:Name="pendingScaling" RelativeTo="Size" Y="-1"/>
        <Set Target="eventTabStates.Active" Value="pendingState"/>
        <Set Target="eventNav.Active" Value="pagePending"/>
        <Callback Handler="{loadData}"/>


in other words, this crappy screenshot shows that i can click on the green zone but not in the red zone, in my iphone. The simulator allows me to click on green and red zones. I’ve tried with Clicked and Tapped, same result.

Please let me know if you need more info.

Thanks in advance!

I’m not exactly sure about the first case, it might be a bug, but I’d need someone else to take a look.

As for your second question, try using HitTestMode="LocalBoundsAndChildren" on your Panel. I think the issue there is that you’ve added a Tapped trigger to the Panel, but the TabText for some reason is stealing focus and not allowing you to “tap” through it.