Connecting to proxy...

On Android Preview I get a Connnecting to proxy… that takes a long time to go away.

When it does go away, it keeps saying Failed to connect to proxy: Connection Refused. Connection Timed Out

Is your Android device and the computer running Fuse connected to the same network?

Yes. They are connected to the same network.

Are you on Windows or OS X? Does the preview app tell you which IP it tried to connect to? Is that the public IP of your computer? Can you try to just restart Fuse? (Just use “Quit” from the tray menu.)

Sorry, this post got buried… I am on a Mac. I checked the IP to confirm that it was indeed the same. Restarting Fuse at the time did not fix it. Let me try it again when I get home… mayber there is some sort of thing wrong with my work computer.

Ok, let us know how it goes. Could it be that you’re running a firewall which blocks the connection btw?

@Andres, I have the same issue. I just started using Fuse and I cannot see a preview on Android. I am using Windows 10 and my Nexus is being detected by adb. Here is the screenshot of what I see on my nexus device.

C:\Users\parva\AppData\Local\Android\sdk\platform-tools>adb devices List of devices attached 07f013ca device

I have the issue, but I have the Foreign Code (ObjC) in my project. If I take away the Foreign Code (ObjC), everything is work.

Preview detected an unhandled exception: Outracks.Simulator.FailedToConnectToProxy: Failed to connect to proxy: Invalid format: Unable to convert string to int

parva.thakkar Are you on Windows or OS X? Could it be that you have a firewall blocking the connection? Are you running Fuse in a virtual machine? Could it be that there’s some other strangeness with your network, for isntance that the Android device you’re previewing on is sharing its internet connection with your computer?

Elliot, Anders,

I’ve been having the same issue as Elliot on Android Preview, but added to that I get “Connection Lost” every 5 minutes or so on Local preview.

I’m running 0.9.10 on Windows 10. Fuse’s ports seems to be free to work properly over Firewall.

Hi everyone,

For now at least, preview on device requires that the code still builds for local preview. If fuse preview does not work, then fuse preview -t=android (or ios) will be stuck at “connecting to proxy”.

That error message is of course not very helpful and will be improved :slight_smile:

Nando: Thanks for reporting, we’ll investigate your issue. I don’t think it’s related to the “Failed to connect” issue above though.

Hey guys,

I know im a bit late with answering this… If you have the connection refused - connection timed out error, it is most likely that WINDOWS FIREWALL blocked Fuse.

To fix this do the folowing:

  1. Go to Firewall settings,
  2. Advanced settngs
  3. Inbound Rules
  4. Find Fuse, and see if it is blocked.

This worked fine for me. Now it’s working just right now. :slight_smile:
I have a 64bit Windows 10 pro edition.

Good luck