Can I use node_module (module of Node js) in Fusetools?

Hi everyone. I’m currently developing the app with fusetools on Windows, and I need to use some module in Node js, by using: npm install But when I included it into the project, and I tried to run: fuse preview and it showed the error like this

E0000: Configuration failed: The specified path, file name, or both are too long. The fully qua lified file name must be less than 260 characters, and the directory name must be less than 248 characters. Error E3114: There is nothing named ‘Uno’ accessible in this scope. Are you missing a package reference?

And it failed, but when I tried to move the node_module to another directory seperately. And it worked well. So I think node_module causing the problem.

So How can I use node_module in fusetools on Windows without getting this such errors?


This is a Windows file system issue. Windows simply doesn’t support long file or path names (which can happen pretty easily unfortunately).

Moving your modules-directory was indeed a functioning workaround.

Just exclude “node_modules” folder in .unoproj file.

As David said, just exclude like this in the project file:

  "Includes": [
  "Excludes": [