Android TextAlignment Render

Hello Fuse Team,

I just want to say you guys are doing a great job with fuse and it’s amazing and wonderful as it’s, However when I was finishing up my App I encountered weird bug which is related to TextAlignment, TextAlignment is working fine on IOS and it’s aligned right and everything looks great however when I preview the App on my android device everything that has TextAlignment is Aligned to Left!
![file]( PM.png)

so yeah it’s so weird and when I remove TextAlignment, IOS renders text to be aligned left which is the default but the Android takes the text to be aligned right, once it detects it’s an RTL font it makes the font Aligned to Right.

2- one more thing sometimes when I preview the app on Android I get this weird message says “Too many open files”, I have no idea what does that mean I even restart my computer and I open Fuse and preview it , it gives back the same error “Too many open files”

3- is there share native api that allow me to share via the applications or facebook, or whatever ?.


Thanks for your report and for your encouraging words.

  1. I’ve created an internal issue for the TextAlignment issue. That sounds like a bug to me. We’ll keep you posted on the progress here.

  2. I haven’t seen that before. Perhaps someone else can chime in? If this continues to be an issue please create a separate thread for it. If you want better answers in the future I would encourage you to create separate threads for separate issues, as it’s then easier for the reader to tell from the title if it’s something they may have an answer to.

  3. There is no pre-made share API yet unless someone in the community has made one that I’m not aware of. For now you may have to do it yourself using foreign code. There have been discussions internally about implementing this, but it hasn’t been started yet as far as I know, so I would only bet on that in the long term.

Thanks again!

Regarding 2): Until we manage to fix the issue with too many open files, try setting ulimit -n 2048.

Thanks for your quick responses, Its really appreciated, Sorry if I ended up putting more than one issue in one thread, didn’t know and will be waiting for your responses towards this bug.

@Anders Schau Knatten I have tried the code you sent in my terminal and then started android preview and this is what I have got.

Fuse 0.30.0 (build 8529)
Build started: FullCompile
Configuring (0.8 s)
Compiling syntax tree (2.8 s)
Generating code and dataFontconfig error: Cannot load default config file
 (8.9 s)
Building Android app
2/2: ThreeBont.apk
(9.9 s)

Build completed in 22.49 seconds
Build ended
Installing APK on 1 device(s)
Launching activity 'ThreeBont'Uno process gone. Killing 16202
/Users/mostafa/Desktop/ThreeBont/build/Android/Preview1/ line 24: 16202 Killed: 9               /Applications/ /Applications/ launch-apk "ThreeBont.apk" --package=com.apps.threebont --activity=ThreeBont --sym-dir="ThreeBont/app/src/main/.uno" "$@"
fuse: Android run failed

Did the app start on the device at all, and if it did, did you get any error messages from it?

No it does not run at all

What kind of device are you trying to run it on? Can you try a full export with fuse build -tandroid -r and see if that works?

I have tried that as well however it gives me the same results which is weird working on ios perfectly fine but not on android