Android export FileSystem error

OS: Windows 7

Fuse Version: 0.31.2 (build 9180)

My Code (at the exact moment of posting):

Tested on:

  • Samsung Galaxy Note 10.1 2014 edition - Android 5.something (I think)
  • Samsung Galaxy S5 - Android 6.0.1

Error logs:

  1. CMD:

What I did:

  1. Wrote code
  2. Tested code in preview
  3. Exported my project directly to the device using: fuse build --target=Android --run (error log 1)

I have also tried to use the normal export option in the GUI with no luck.

In the preview the app works exactly as expected, but when I export it all the dynamic stuff seems to stop working.

App preview screenshot:

Why I think this is a bug in FuseTools and not a bug in my code:

  1. It works perfectly in the preview but not in the export
  2. I assume that the error originates from Permission Denial: getCurrentUser() from pid=17054, ui
    d=10262 requires android.permission.INTERACT_ACROSS_USERS. I tried googling it to find a solution, but accoring to this StackOverflow post it doesn’t seem like it’s that easy to fix:

If you need any more info to reproduce the error, please let me know, I’ll be happy to help :slight_smile:

Merry xmas, and thanks in advance.

  1. When you say it works perfectly in the preview, do you mean local preview or preview on device?
  2. The error log say you got problems reading/writing to your file path.
I/SkiLogg (17054): Error: JavaScript error in MainView.ux line 164: Name: Uno.IO
I/SkiLogg (17054): Error message: Couldn't open file: /data/data/com.apps.skilog
The permisson problem you are talking about is only a warning and I don't think it's related to Fuse.

After a quick look at your code, I would recommend to remove all your sync read/write calls and use the promise based instead. It will currently block your UI from updating and make your app feel laggy.

Thanks for the reply.

  1. It works as expected in local and android preview.

I’ll try to update everything to async soon, and will come back with an update