Android build fail on windows 10 fuse v0.12.3

Hi, i’ve just started learning fuse. But when i wanted to preview on Android, i get error as below:

Build started: FullCompile
Configuring (6.51s)
Compiling syntax tree (11.92s)
Generating code and data (29.71s)
Building Android app
/Android/android-sdk\extras\android\support\v4\android-support-v4.jar"" was unexpected at this time.
(unknown): E0200: Android build failed -- rerun with '-v' for more information
?: Error E0200: Android build failed -- rerun with '-v' for more information

Build completed in 55.06 seconds.
    0 Warning(s)
    1 Error(s)
Checking if C:\Program Files\Java\jdk1.8.0_60 exists.
C:\Program Files\Java\jdk1.8.0_60 was found.
Checking if JDK is corrupt
jdk was found.
Checking if C:\Program Files (x86)\Android\android-sdk exists.
C:\Program Files (x86)\Android\android-sdk was found.
Checking if C:\Program Files (x86)\Android\android-sdk\tools exists.
C:\Program Files (x86)\Android\android-sdk\tools was found.
Checking if Android SDK is corrupt.
Checking if all required Android components are installed.
androidsdk was found.
Checking if C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\AndroidNDK\ndk-build exists.
C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\AndroidNDK\ndk-build was found.
Checking if C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\AndroidNDK\toolchains exists.
C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\AndroidNDK\toolchains was found.
Checking if C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\AndroidNDK\prebuilt exists.
C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\AndroidNDK\prebuilt was found.
androidndk was found.
Checking if C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\Ant exists.
C:\Users\qusya\AppData\Local\Fusetools\Fuse\Android\Ant was found.
Checking if Ant is corrupt
ant was found.
Build ended
fuse: Failed to compile project
Press any key to exit.

I then modified C:\ProgramData\Uno\Packages\UnoCore\0.27.20\Targets\Android\build.bat at line 17, i removed this text: at "%SUPPORT_JAR%"

then, i run uno clean and run the preview again, it worked.

I feel this is a bug?

It is! thankyou for posting. This particular issue has been cropping up for a short time. We will get this change in asap.

Thanks again

Hi i’ve got this error too!

Booo at bugs!

Sorry nico, rest assured the fix is in the next release.

Here is a workaround

  1. Open %PROGRAMDATA%\Uno\Packages\UnoCore\0.27.20\Targets\Android\build.bat
  2. Change line 17 from echo ERROR: expected jar at "%SUPPORT_JAR%" to echo ERROR: expected jar at %SUPPORT_JAR%
  3. Afterwards, run uno clean before running fuse preview -t=android

worked for me , the path was a bit different ProgramData\Uno\Packages\UnoCore\0.27.20\Targets\Android

Thank you, I have updated my answer :slight_smile:

This issue is fixed in Fuse 0.12.4