Unhandled exception on starting Fuse

Please find the attached log below. Any solution?

I am running it on Mac 10.10.5, I’ve followed the setup guide.

kennys-Mac-mini:Downloads Kenny$ fuse
Unhandled exception: Object reference not set to an instance of an object
exception inside UnhandledException handler: Could not find a valid superclass for type NSProcessInfo. Did you forget to register the bindings at MonoMac.ObjCRuntime.Class.Register() or call NSApplication.Init()?

[ERROR] FATAL UNHANDLED EXCEPTION: System.NullReferenceException: Object reference not set to an instance of an object
  at Outracks.Fuse.ModuleInstaller.FuseModulesInstaller.<UpdateCacheIfNeeded>m__0 (Outracks.IO.AbsoluteFilePath f) [0x00000] in <filename unknown>:0 
  at System.Linq.Enumerable.First[AbsoluteFilePath] (IEnumerable`1 source, System.Func`2 predicate, Fallback fallback) [0x00000] in <filename unknown>:0 
  at System.Linq.Enumerable.FirstOrDefault[AbsoluteFilePath] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0 
  at Outracks.Fuse.ModuleInstaller.FuseModulesInstaller.UpdateCacheIfNeeded (IProgress`1 progress) [0x00000] in <filename unknown>:0 
  at Outracks.Fuse.ModuleInstaller.FuseModulesInstaller.GetModules (Optional`1 progress) [0x00000] in <filename unknown>:0 
  at Outracks.Fuse.Commands.InstallCliCommand..ctor (Outracks.Fuse.ModuleInstaller.FuseModulesInstaller installer, Outracks.CLI.ColoredTextWriter coloredTextWriter, Outracks.CLI.ColoredTextWriter errorTextWriter) [0x00000] in <filename unknown>:0 
  at Outracks.Fuse.Program.Main (System.String[] args, System.Func`2 host, Outracks.Fuse.Platform fusePlatform) [0x00000] in <filename unknown>:0 
  at Outracks.Fuse.Entrypoint.Main (System.String[] cmdArgs) [0x00000] in <filename unknown>:0

Hey Kenny, we’ve seen this in rare cases but are still working on narrowing it down. Could you do us a favor and check if making a clean uninstall of Fuse and reinstalling solves this? That is, delete Fuse.app from your Applications folder before running the installer?

If not, does a reboot help?

Thank you for your quick reply, Andreas.

It is working after re-installling Fuse. :wink:

Cheers, Kenny

Great to hear!

I had the same issue on my MacBook Pro 10.10.4. Installed Mono and then Fuse. Installing Fuse again worked for me asweell. So it seems something is missing which is in place when install a second time.

That’s correct, there was a bug in the 0.5.3564 installer that came out a few days ago, this was corrected in 0.5.3709 that came out last evening.

No its not! I have 0.5.3709 and this is the only version I have tested of Fuse. So the bug is still there.

Hi again, you’re correct. I got two threads confused, we are still looking into this issue.

This has been solved in 0.5.3715.