Stackpanel dock="Top" not fill overlap


Overflow Fill color not working in dock=“Top” stackpanel. Is there any solution… Give me

Once Remove Dock=“Top” from Stackpanel Working Fine. why???


App can have only a single node in it (we have an issue to produce an error when there are more). In your sample code the Rectangle is just completely ignored and the StackPanel becomes the only child. This also means Dock="Top" does nothing since it isn’t inside a DockPanel (note that ClientPanel is a type of DockPanel).

<App Theme="Basic" Background="#fff">
        <Rectangle Filll="#000" ux:Name="fader" Layer="Overlay"/>
        <StackPanel Dock="Top" ux:Name="TopHeader">...</StackPanel>

I’m not certain what you’re trying to achieve, I’m guessing a black fader on top of the panel. Notice that I put Layer="Overlay" on the Rectangle, this takes it outside of the normal layout and positions it on top of the other children. The default layout settings also ensure it is stretched to fill the entire parent, the ClientPanel in this case.

Super Bro :slight_smile:

I have only add Layer=“Overlay” Property… Working Fine

Good :slight_smile: