Problem with Android source

Just downloaded SwipePlaces example. The preview seems awesome and I wanted to generate sources and build an APK.

I went to the folder and wanted to export to Android using :

fuse build --target=android


Building native target

Running D:\projets\CSM\fuse_examples\SwipePlaces\.build\Android-Debug\build.bat

ERROR: ant.bat was not found in ‘\bin’

Here is the beginning of build.bat file :

REM Setup variables

set ANT_DIR=


set NDK_DIR=

set SDK_DIR=

I filled the values and tried to launch build.bat but got this :

Building SO make: * No rule to make target /sources/cxx-stl/stlport/libs/armeabi-v7a/libstlport_static.a, needed by libs/armeabi-v7a/ Stop.

Can you post the output from fuse install -s android?

And maybe try to run fuse install android

Hi Michael,

You’ll need to install the Android SDK & NDK first. You can do this by typing fuse install android

(Note: if you already have some of these packages installed elsewhere on your system then this installation process also lets you reuse those by providing the correct path. That said, if you’re unlucky you might get some version collisions in that case, so if you experience any issues just try to reinstall as described above).

We also have an existing ticket to provide a more sensible error message for the case when Android SDK parts are missing.

Thanks for replies.

I used fuse install android to set the path to already existing tools.

It might be a good thing to add something in the documentation about that near the Export part.

New error: is not on the classpath.

Perhaps JAVA_HOME does not point to the JDK.

It is currently set to “C:\Program Files\Java\jre1.8.0_65”

My JAVA_HOME however is set to JAVA_HOME="c:\java\64bits\jdk1.8.0_65"

Good point, I’ve added a note in the handbook about the Android export.

We’ll get back to you asap on the Java path issue. In the meantime could you do fuse install -s android and paste the output here? (That command will check the status of all the necessary components, without installing anything new).

Remi I modified the sdkConfig.json file in .../local/FuseTools/Fuse

By default it looks in %programfiles%\java for the pattern : jdk.

I personnally installed my JDKs elsewhere so it was taking the only folder I have there : the JRE.

I used : {"Path":"C:/java/64bits","PathPattern":"jdk*"}

And the built was successful.


Thanks for the feedback and happy that it worked out! :slight_smile: We’ve made a ticket to also support custom paths for the JDK.