Preview on Android device throwing Uno.NullReferenceException, but working on local preview


I’m working on an app that worked fine, then I got a notification on windows that a new update is available,I did the update and then my preview stopped working on android. I uninstalled fuse , reinstalled the latest version ( but still no luck. I have tested this on two android devices.

The preview starts on the device but as soon as I click on anything I get this:

ERROR: Object reference was null Uno.NullReferenceException occured.

LOG: Unrooting happening after the mixers update phase Fuse.Controls.DockPanel

Thank you, Pieter

Hi Pieter,

Could you please see if this is a problem with normal builds as well? (fuse build -t=android --run instead of fuse preview.)

Do you remember which version you had before 0.9.5?

Could you send us your project so we can debug it here? If you upload it to, it can only be accessed by the Fuse team.

Hi Anders,

I did deploy it on the phone but I forgot to mention that(not preview).

With regards to the version it must have been Version becuase I downloaded it very recently.(I’m guessing this based on the fact that windows asked me if I wanted to update Fuse). I also uploaded the project on dropbox.



Hi Pieter,

I can reproduce the bug here, we’ll investigate and fix. Thanks for reporting!

This issue has been fixed, and the fixed version should be available soon.

I see it’s working now, thanks !

Great to hear that you got it working! For anyone else seeing this issue, please upgrade to Fuse 0.9.6.