Fuse Sketch import - Throwing System.UnauthorizedAccessException

Hi, sorry if there’s duplication for this type of exception. I’m trying to generate simple project using fuse import , but it thrown an exception after a while during importing assets.

Here’s simple snippet for error:

`Unhandled Exception: System.UnauthorizedAccessException: Access to the path 'IPU.sketch-assets/temp/' is denied.

at System.IO.FileStream…ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000] in :0`

I’ve tried to make full access for project-assets folder, but when I try to re-run fuse import file.sketch, it still failed caused by unable to write into /tmp/ folder.

*Same error occurred even if I try run with sudo option.
Using MacOSX(10.10.5), Fuse(v0.8.2) build 4544, sketchtool Version 1.4 (305)


Thanks for reporting this. Can you please provide the sketch file you are using as a test case?

Hi, sorry it took long to reply. It’s just hard to trace back issue created by me. However, here’s the sample sketch file:


Thanks for replying, and looking forward for your assistance.

The problem is identified, and is not about access to your path. It has to do with the extraction of the fonts.