Fuse does not create .local/share folder

I formatted my mac yesterday, and install everything… when I run fuse it throws the following error:

System.IO.DirectoryNotFoundException: Could not find a part of the path "/Users/raphael/.local/share/devices.json".

so I create the path “/Users/raphael/.local/share/” and everything work properly.

Fuse version 1.5.0 (build 15046)

Thank you! Experienced the same as you - to resolve I created the full path where I was having similar issue (in my case, .local/share/FuseLocalStorage) and was still getting an access denied error.

Tried your simple resolution and works now; still needs research by the team, but thank you for the approach.

@raphael.godoi, what did you do that triggered this error?

Fuse does use a file devices.json, but normally shouldn’t be looking for it in that folder. Does your project happen to also use a file with that name?


I got this error when I tried to read or write in storage:

Storage.writeSync("devices.json", JSON.stringify(data));

the file “devices.json” is from my project…
The problem is that fuse is not crating the folder “$HOME/.local/share” folder, for some reason… I think this folder is used for local preview storage…

I created this folder manually and everything works.

Thanks for the additional detail @raphael.godoi! I’ve logged an issue for this now.