[0.20] Cannot preview on Android

My app worked fine with 0.12, locally and on device, preview and build. However, when I run fuse preview -t=Android now, I get this:

Generating code and data (25.96s)
Building Android app
1/2: libPair.so
jni/_root.MainView.cpp: In member function 'void g::MainView::InitializeUX()':
jni/_root.MainView.cpp:770:6: note: variable tracking size limit exceeded with -fvar-tracking-assignments, retrying without
 void MainView::InitializeUX()

It’s not clear what I’m doing wrong or whether it’s a bug in Fuse or not.

Edit: after letting it run for 300 sec, it eventually installed on device. Still not sure if bug or not (it was not taking this long before)

Did you make sure to uno clean?


Hi Cyril,

Could you please see if it takes about the same time to do fuse build -tandroid as to do fuse preview -tandroid?

Also, is there any chance you could share your project with us to help with debugging? If you upload it to https://www.dropbox.com/request/ZgndLtJQm5eGzG9cicGK, it can only be accessed by the Fuse team.

Hey Anders, well I tried to time the two but couldn’t reproduce. I don’t get the error anymore (while I was getting it consistently yesterday :/) and the build times are back to normal.

That’s strange. If it happens again, could you please try the steps outlined above?

It’s good that you got rid of the problem, but I don’t like that we didn’t find out what caused it.