process:easy: DuplicateHandle(ln) failed (e=6) while building for Android (in build.bat)


As you can see, the error occurs just after build.bat has started running. If I run build.bat from the command line, it works.

This post onn stackoverflow seems to be related:

Hi spookysys,

We’re unable to trigger the issue here, but invoking make in a new instance of cmd.exe might be a workaround.
Could you try making a little adjustment in build.bat and see if that fixes the problem?

The original file should be located here: C:\ProgramData\Uno\Packages\UnoCore\0.1.0\Targets\CPlusPlus\Android\build.bat
Change line 32 to this: cmd /c %MAKE% -j %NUMBER_OF_PROCESSORS% || goto ERROR

I didn’t help… I did check that it propagated correctly to the .bat file that was executed. Some posts on the internet speculate that it has to do with gmake and a cygwin dll-file… are you using such things?

Thanks for trying!

We only use make.exe and compiler toolchains that are included in the Android NDK. That’s some sort of gmake, but we’re not using cygwin.

We’ve found a computer that triggers the issue, will investigate more.

We’ve found a solution. Will release a fix shortly.

Confirming that this works now! :wink: