Fuse Community

64-bit warning when releasing an Android app

You can follow the progress from the ticket. I’m pretty sure the issue will be fixed soon.

I also have an application made in FUSE, I’m hoping for this solution.

Hi guys… any Progress on this?

I saw in Slack that Morten’s gonna get started on it soon.

64Bit supports is here: https://github.com/fuse-open/uno/pull/186

1 Like

HI Ichan

When it’s supossed to be released the next versión with this included?

it is released couple days ago. Now fuselibs and uno is distributed using NPM. You can install the update using : npm install -g fuse-sdk command. more info here

Hey! And sorry for being nooby x)
I dont get this working…

I have Fuse 1.10 installed and tried npm install -g fuse-sdk but I get an error with:
android-build-tools could not be found

If you want to build Android apps it is recommended to install this package using the following command:

npm install -g android-build-tools

+fuse-sdk@1.12.0-rc.4
updated 1 package in 1.14s

when I run ‘npm install -g android-build-tools’ I get:

The command “bash” is either misspelled or
could not be found.
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! android-build-tools@0.3.2 install: bash install.sh
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the android-build-tools@0.3.2 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Username\AppData\Roaming\npm-cache_logs\2019-07-14T00_35_29_062Z-debug.log

What am I doing wrong? In wich directory I have to run this command?
I hope I’m not ridiculous x)

Thanks for help (=

@Georg Please try to rerun npm install -g android-build-tools.

I just published a new version of the package that automatically detects Bash on your system.

If it still doesn’t work please install Git for Windows (includes Bash) to solve the problem. You can get it at https://git-scm.com/downloads

@mortend thank you very much :slight_smile: but there is no finish success xD
now I get this error:

Found Bash at E:\Programs\Git\usr\bin\bash.exe Found JDK8 at C:\Program Files (x86)\Common Files\Oracle\Java Downloading https://dl.google.com/android/repository/sdk-tools-windows-4333796.zip Extracting to C:\Users\username\AppData\Local\Android\sdk Accepting licenses
ERROR: Install failed – please read output for clues, or open an issue on GitHub. Note that Java 8 (not 9+) is required to install Android SDK. npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! android-build-tools@1.0.0-rc.1 install: node install.js npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the android-build-tools@1.0.0-rc.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

java 8 and node.js is installed :v:t3:

sorry for taking your time :confused:

@Georg No worries. I’ve published another version with improved JDK detection and error reporting.

I believe the problem is with the JDK. If it still doesn’t work, please try the OpenJDK from https://adoptopenjdk.net/

Thaank you very much :pray: now it works! :slight_smile:

buut :D:D
If I start “npm install -g fuse-sdk” it looks like it finished successfully

  • fuse-sdk@1.12.0-rc.4
    updated 1 package in 1.41s

but when I start “uno --version” it even says

Uno version 1.10.0-rc1

Dont even know, if it is another Problem, or does it matter with this here? :speak_no_evil:

Thank you so much (=

Woah, that’s good! :slight_smile:

So now your problem is that an older version of Uno, probably from an older Fuse Studio install, takes precedence in PATH.

  • Solution 1: Uninstall Fuse Studio if you no longer use it, or
  • Solution 2: Edit your PATH variable and move %APPDATA%\npm so it comes before Fuse.

You can run where uno to see where your different uno’s are located. And shuffle your PATH until the right one comes out on top.

λ where uno
C:\Users\morten\AppData\Roaming\npm\uno
C:\Users\morten\AppData\Roaming\npm\uno.cmd

And thanks for testing. Your feedback helps us improve.

Solution 1: It works like you said :+1:

But I want to use Fuse Studio to Display changes on my Desktop. Therefore I tried Solution 2 :smiley:
I searched in “system->system-variable” for npm in Path, but there is nothing named like this, so I created a new one. But nothing changed.

I think there I somethink I am doing wrong :confused::v:

On my system the path is C:\Users\morten\AppData\Roaming\npm (aka %APPDATA%\npm).

If it doesn’t exist in System Variables you can add it, and make sure it is above the Fuse Studio path.

In “Uservariables” there are only two elements:

%USERPROFILE%\AppData\Local\Microsoft\WindowsApps
C:\Users\user\AppData\Roaming\npm

But nothing called Fuse…
In “Systemvariables” there are a lot elements…
One for Fuse but nothing for uno

C:\Program Files (x86)\Fuse\

So I added new one:

C:\Users\morten\AppData\Roaming\npm

But my Version is still 1.10 when I get “uno --version” :confused:

Make sure C:\Users\user\AppData\Roaming\npm is above C:\Program Files (x86)\Fuse\ in System Variables and I believe it should work. :slight_smile:

Note that you have to replace morten (my name) with your user name. :wink:

where uno should print something similar to this.

λ where uno
C:\Users\morten\AppData\Roaming\npm\uno
C:\Users\morten\AppData\Roaming\npm\uno.cmd
C:\Program Files (x86)\Fuse\uno.exe

It’s crazy…I did not change anything, but now it displays the correct version :+1:
Maybe there was a Process wich needs to be restarted, or I had to reboot the system…
But Thank you very much :slight_smile: (=

Oh yeah, cmd.exe must be restarted after making changes in your environment.

Cheers!

Capture
i compiled my project into 64 bit then i upload into production i got this warning.
what can i do?
“SDK”: {
“CompileVersion”: 28,
“MinVersion”: 19,
“TargetVersion”: 28
},
“Architectures”: {
“Release”: [“armeabi-v7a”, “arm64-v8a”]
},
i included this in my uno project.is this correct?